Anonymous,

Please Login or Register
Download Nuke Evolution Xtreme today for a CMS you can enjoy using and sharing with your friends!
[ Download Now ]
Forum Index  ·  Search  ·  Usergroups  ·  Edit your profile  ·  Members  ·  Login, Check Messages
Arcade  ·  Ranks  ·  Staff  ·  Statistics  ·  Board Rules  ·  Forum FAQ  ·  Log in

Search for at
Evolution-Xtreme Advanced Search


+  
Latest Site News   Next 5 >>  
 Forum   Author   Replies   Last Post 
File Repository 1.0.0 Released Announcements! Lonestar 0 Tue Apr 26, 2016 6:44 am
Lonestar View latest post
Image Repository Released Announcements! Lonestar 1 Mon Oct 27, 2014 7:39 pm
Lonestar View latest post
So what happened to us? Announcements! SgtLegend 0 Tue May 06, 2014 12:32 am
SgtLegend View latest post
[PROGRESS] Nuke Evolution Xtreme 2.0.9e Announcements! SgtLegend 2 Sun May 27, 2012 6:25 pm
SgtLegend View latest post
European Cookie Law Announcements! SgtLegend 0 Sat May 26, 2012 7:33 am
SgtLegend View latest post
   
Recent Topics   Next 15 >>  
 Forum   Author   Replies   Last Post 
Evo staff looking for some volunteers. Community Announcements coRpSE 20 Thu Jul 02, 2015 9:19 am
Depresjon2 View latest post
Evo Xtreme 2.0.9D Updated for PHP 5.6 General Support coRpSE 121 Thu Mar 23, 2017 3:57 pm
casterdon View latest post
[ MOD ] - Honeypot V2.2 AntiBot Module Security coRpSE 106 Tue Nov 22, 2016 11:30 am
coRpSE View latest post
Possible new Admin area layout Comments and Suggestions Lonestar 18 Wed Sep 14, 2016 11:37 am
Blackou View latest post
jQuery update General Support Lonestar 2 Wed May 11, 2016 4:49 pm
Charles64 View latest post
Deutsche Sprachdatei - german language files German DT50R 7 Thu Jan 28, 2016 7:04 am
DT50R View latest post
[FIX] Correct Cookie Settings (Invalid Session Error) Quick fixes killigan 110 Fri Mar 20, 2015 1:06 pm
Macdaddy View latest post
Looking for coRpSE? He is gone till May. General Chat coRpSE 2 Wed Mar 22, 2017 2:47 pm
casterdon View latest post
error log Bugs Redcougarxr7 31 Tue Mar 21, 2017 8:46 pm
coRpSE View latest post
Think I got hit with malware somehow General Support bobdude 7 Sat Mar 18, 2017 12:00 pm
coRpSE View latest post
I seem to be locked out of my website Smile General Support storm 4 Sat Mar 11, 2017 12:29 pm
coRpSE View latest post
Site gone off General Support GI_ 3 Fri Mar 03, 2017 11:21 am
Lonestar View latest post
Norwegian Language Multilingual Support dogbone 0 Wed Mar 01, 2017 10:43 pm
dogbone View latest post
Arcade General Support Reaper2388 59 Sun Feb 26, 2017 7:13 pm
pholix View latest post
all blocks General Support Worfwarrior 6 Sat Feb 25, 2017 4:41 pm
coRpSE View latest post

WhoIsWhere error from custom_head.php

 
Post new topic    Reply to topic    printer-friendly view   Thank Post    Evolution-Xtreme Forum Index -> General Support
View previous topic :: View next topic  
Author Message
coRpSE
Xtreme Developer
Xtreme Developer
Site Admin
Site Admin
Support Team
Support Team



Gender: Gender:Male
Joined: Dec 24, 2008
Age: 36
Posts: 1348
Location: Back of your mind!!!
Reputation: 185.5
votes: 10
usa.png


Status: Offline
Web Control Panel: 11.42.0 (build 23)
PostPosted: Wed Dec 28, 2016 1:09 pm Post subject: No icon WhoIsWhere error from custom_head.php Reply with quote

 For  anyone  that  had  an  error  show  up  in  your  error  log  like  this:
 
 
                                                 
Quote:                
Date                     Time              IP                                    Message
 ---------[SQL  Error]------------------------------------------------------------------------------------------------------------
    -  [26  Dec  2016  -  23:54:06]  -  
 User:  
 IP:  217.72.117.47
 URL:  /modules.php?name=MyModule'A=0
 
 File:  public_html/includes/custom_files/custom_head.php
    Line:  794
 Message:  You  have  an  error  in  your  SQL  syntax;  check  the  manual  that  corresponds  to  your  MySQL  server  version  for  the  right  syntax  to  use  near  'A=0')'  at  line  1
 Code:  1064
 Query:  INSERT  INTO  nuke_whoiswhere  (username,  time,  host_addr,  guest,module,url)  VALUES  ('217.72.117.47',  '1482796446',  '217.72.117.47',  '1','MyModule\'A=0','/modules.php?name=MyModule'A=0')
 ---------------------------------------------------------------------------------------------------------------------------------                

 
 Well,  I  believe  I  got  that  fixed.  To  fix  it  is  simple:
 
 Open:  public_html/includes/custom_files/custom_head.php
 
 Find:  (Around  Line  57)
 
                                                 
PHP:                
$url $db->sql_escapestring($_SERVER["REQUEST_URI"]);                 

 (Note:  if  you  don't  have  that  one  line,  skip  to  the  section  labled  "Updated"  below.)
 
 Replace  with:
 
                                                 
PHP:                
$url $db->sql_escapestring($_SERVER["REQUEST_URI"]);
$url addslashes($url); 
               

 
 Save  &  Close
 
 If  done  right,  that  section  should  now  look  like  this:
 
                                                 
PHP:                
$ip $db->sql_escapestring($_SERVER["REMOTE_ADDR"]);
$url $db->sql_escapestring($_SERVER["REQUEST_URI"]);
$url addslashes($url);
$uname $db->sql_escapestring($cookie[1]); 
               

 
 That's  it.  Originally  I  was  going  to  go  a  different  route,  but  after  talking  to  Lonestar,  this  seemed  to  be  the  best  way  to  go,  so  as  long  as  it  works.  So  far,  my  testing  proved  that  it  is  working  as  intended.
 
 
 

 
 Updated:
 
 If  you  don't  see  that  one  line  that  was  mentioned  above,  then  do  these  instructions  instead.  Thanks  Shadz  for  pointing  this  oversite  out  to  me.  This  was  an  update  that  was  done  back  in  2012,  Link  found  here:  http://evolution-xtreme.com/modules.php?name=Forums&file=viewtopic&p=36585#36585
 
 FIND:
 
                                                 
PHP:                
$ip $_SERVER["REMOTE_ADDR"];
    
$url $_SERVER["REQUEST_URI"];
    
$uname $cookie[1]; 
               

 
 REPLACE  WITH:
 
                                                 
PHP:                
$ip $db->sql_escapestring($_SERVER["REMOTE_ADDR"]);
$url $db->sql_escapestring($_SERVER["REQUEST_URI"]);
$url addslashes($url);
$uname $db->sql_escapestring($cookie[1]); 
               

 
 Save  &  Close
 
 That  should  be  it.


Last edited by coRpSE on Fri Dec 30, 2016 6:41 pm; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
Worfwarrior




Joined: Sep 28, 2015
Posts: 30

Reputation: 3.8


Status: Offline
PostPosted: Thu Dec 29, 2016 6:37 am Post subject: No icon Re: WhoIsWhere error from custom_head.php Reply with quote

 that  fixed  it  for  me  apart  from  it  shows  an  ip  address  at  this  location   Missions'A=0  that  does  not  exist
 
 when  I  click  the  link  it  takes  me  to  error  page  with  the  message  
 Sorry...  but  this  module  does  not  exist!
    
 
 but  the  error  is  fixed  or  at  least  no  longer  logged
Back to top
View user's profile Send private message
Lonestar
Site Admin
Site Admin
Xtreme Developer
Xtreme Developer




Joined: Oct 09, 2008
Posts: 425

Reputation: 58.3
votes: 3
blank.png


Status: Offline
PostPosted: Thu Dec 29, 2016 6:56 am Post subject: No icon Re: WhoIsWhere error from custom_head.php Reply with quote

 The  reason  you  get  this  error  is  because  at  the  location  the  link  is  taking  you,  That  module  DOES  NOT  actually  exsit,  Simply  because  the  website  is  taking  "Missions'A=0"  as  the  module  name  and  not  "Missions"
 
 There  is  no  error  Razz
Back to top
View user's profile Send private message Send e-mail
Sponsor
phpstorm.jpg
Worfwarrior




Joined: Sep 28, 2015
Posts: 30

Reputation: 3.8


Status: Offline
PostPosted: Thu Dec 29, 2016 8:36 am Post subject: No icon Re: WhoIsWhere error from custom_head.php Reply with quote

                                                   
Lonestar  wrote  (View  Post):                
The  reason  you  get  this  error  is  because  at  the  location  the  link  is  taking  you,  That  module  DOES  NOT  actually  exsit,  Simply  because  the  website  is  taking  "Missions'A=0"  as  the  module  name  and  not  "Missions"
 
 There  is  no  error  Razz                

 
 
 yeah  I  agree  and  understand,  I  think  in  the  script  there's  a  typo
Back to top
View user's profile Send private message
coRpSE
Xtreme Developer
Xtreme Developer
Site Admin
Site Admin
Support Team
Support Team



Gender: Gender:Male
Joined: Dec 24, 2008
Age: 36
Posts: 1348
Location: Back of your mind!!!
Reputation: 185.5
votes: 10
usa.png


Status: Offline
Web Control Panel: 11.42.0 (build 23)
PostPosted: Thu Dec 29, 2016 6:36 pm Post subject: No icon Re: WhoIsWhere error from custom_head.php Reply with quote

                                                   
Worfwarrior  wrote  (View  Post):                
                                                 
Lonestar  wrote  (View  Post):                
The  reason  you  get  this  error  is  because  at  the  location  the  link  is  taking  you,  That  module  DOES  NOT  actually  exsit,  Simply  because  the  website  is  taking  "Missions'A=0"  as  the  module  name  and  not  "Missions"
 
 There  is  no  error  Razz                

 
 
 yeah  I  agree  and  understand,  I  think  in  the  script  there's  a  typo                

 
 This  error  happens  with  all  modules,  there  is  no  typo.  It's  been  an  error  that  I  have  had  on  my  site  for  years  and  seen  on  many  others  sites  but  never  got  around  to  fixing  it  till  now.
Back to top
View user's profile Send private message Visit poster's website
Lonestar
Site Admin
Site Admin
Xtreme Developer
Xtreme Developer




Joined: Oct 09, 2008
Posts: 425

Reputation: 58.3
votes: 3
blank.png


Status: Offline
PostPosted: Thu Dec 29, 2016 6:43 pm Post subject: No icon Re: WhoIsWhere error from custom_head.php Reply with quote

 It  is  not  a  typo,  It's  the  referral  link  creating  the  typo,  nothing  you  can  do  about  it.
Back to top
View user's profile Send private message Send e-mail
Sponsor
webstorm.jpg
Worfwarrior




Joined: Sep 28, 2015
Posts: 30

Reputation: 3.8


Status: Offline
PostPosted: Fri Dec 30, 2016 4:31 am Post subject: No icon Re: WhoIsWhere error from custom_head.php Reply with quote

 Gotcha  turn  of  module  whoiswhere  problem  solved  Smile
Back to top
View user's profile Send private message
Display posts from previous:
Post new topic  Reply to topic   printer-friendly view   Thank Post Evolution-Xtreme Forum Index ->  General Support All times are UTC - 5 Hours
Page 1 of 1


 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Related topics
 Topics   Replies   Author   Views   Last Post 
This topic is locked: you cannot edit posts or make replies. Announcement: [BETA][RELEASED] Nuke Evolution 2.0.8 0 SgtLegend 3740 Fri May 28, 2010 4:54 am
SgtLegend View latest post
No new posts Dutch Language for Xtreme V2.0 4 DFC-NightMare[NL] 3896 Wed May 01, 2013 1:18 pm
coRpSE View latest post
No new posts [Solved] Birhday mod 3.0 missing: 18 Huntergreen 11753 Mon Mar 04, 2013 7:54 pm
Teo View latest post
No new posts help upgrading to evo xtream 2.0.7 1 kirky12 3735 Thu Sep 02, 2010 10:06 am
SgtLegend View latest post
This topic is locked: you cannot edit posts or make replies. [ Poll ] Xtreme v2.0 52 Lonestar 20572 Wed Oct 14, 2009 2:51 am
SgtLegend View latest post
 




Powered by phpBB © 2001, 2006 phpBB Group
EvoXtreme Theme by SgtLegend ©
Forums ©