Anonymous,

Please Login or Register
Download Nuke Evolution Xtreme today for a CMS you can enjoy using and sharing with your friends!
[ Download Now ]
Forum Index  ·  Search  ·  Usergroups  ·  Edit your profile  ·  Members  ·  Login, Check Messages
Arcade  ·  Ranks  ·  Staff  ·  Statistics  ·  Board Rules  ·  Forum FAQ  ·  Log in

Search for at
Evolution-Xtreme Advanced Search


+  
Latest Site News   Next 5 >>  
 Forum   Author   Replies   Last Post 
File Repository 1.0.0 Released Announcements! Lonestar 0 Tue Apr 26, 2016 6:44 am
Lonestar View latest post
Image Repository Released Announcements! Lonestar 1 Mon Oct 27, 2014 7:39 pm
Lonestar View latest post
So what happened to us? Announcements! SgtLegend 0 Tue May 06, 2014 12:32 am
SgtLegend View latest post
[PROGRESS] Nuke Evolution Xtreme 2.0.9e Announcements! SgtLegend 2 Sun May 27, 2012 6:25 pm
SgtLegend View latest post
European Cookie Law Announcements! SgtLegend 0 Sat May 26, 2012 7:33 am
SgtLegend View latest post
   
Recent Topics   Next 15 >>  
 Forum   Author   Replies   Last Post 
Evo staff looking for some volunteers. Community Announcements coRpSE 20 Thu Jul 02, 2015 9:19 am
Depresjon2 View latest post
Evo Xtreme 2.0.9D Updated for PHP 5.6 General Support coRpSE 121 Thu Mar 23, 2017 3:57 pm
casterdon View latest post
[ MOD ] - Honeypot V2.2 AntiBot Module Security coRpSE 106 Tue Nov 22, 2016 11:30 am
coRpSE View latest post
Possible new Admin area layout Comments and Suggestions Lonestar 18 Wed Sep 14, 2016 11:37 am
Blackou View latest post
jQuery update General Support Lonestar 2 Wed May 11, 2016 4:49 pm
Charles64 View latest post
Deutsche Sprachdatei - german language files German DT50R 7 Thu Jan 28, 2016 7:04 am
DT50R View latest post
[FIX] Correct Cookie Settings (Invalid Session Error) Quick fixes killigan 110 Fri Mar 20, 2015 1:06 pm
Macdaddy View latest post
Admin General Support bomclan 3 Sat Jun 17, 2017 6:01 pm
Sp0rAdiC View latest post
RSS feeds Blocks Richmc 1 Sat Jun 17, 2017 5:52 pm
Sp0rAdiC View latest post
Forums disappeared General Support Richmc 0 Fri Jun 16, 2017 9:20 am
Richmc View latest post
admin access help needed General Support Soulfly 13 Fri Jun 09, 2017 3:08 pm
Soulfly View latest post
mysql_error ? General Support Redcougarxr7 5 Thu Jun 08, 2017 8:27 am
coRpSE View latest post
Question about domain name General Support Richmc 0 Wed Jun 07, 2017 11:03 am
Richmc View latest post
PM System not working correctly General Support Worfwarrior 0 Fri Jun 02, 2017 8:24 am
Worfwarrior View latest post
Looking for coRpSE? He is gone till May. General Chat coRpSE 9 Tue May 30, 2017 9:19 am
Soulfly View latest post

deprecated errors

 
Post new topic    Reply to topic    printer-friendly view    Evolution-Xtreme Forum Index -> General Chat
View previous topic :: View next topic  
Author Message
travo



Gender: Gender:Male
Joined: Jan 21, 2009
Age: 24
Posts: 486
Location: Australia
Reputation: 65.1
votes: 2
australia.png


Status: Offline
PostPosted: Sat Aug 01, 2009 5:47 am Post subject: No icon deprecated errors Reply with quote

 Hey,  kinda  embarrassed  to  ask  this,  but  I  just  cant  get  it  working.
 
 I  recently  changed  from  a2t  to  wampserver,  and  transferred  all  of  my  files  across.  The  only  errors  I  have  are  with  nuke  evo
 
 
                                                 
Quote:                
Deprecated:  Function  eregi()  is  deprecated  in  C:\wamp\www\evo\mainfile.php  on  line  163
 
 Deprecated:  Assigning  the  return  value  of  new  by  reference  is  deprecated  in  C:\wamp\www\evo\includes\functions_evo.php  on  line  1070
 
 Deprecated:  Assigning  the  return  value  of  new  by  reference  is  deprecated  in  C:\wamp\www\evo\includes\functions_evo.php  on  line  1072
 
 Deprecated:  Assigning  the  return  value  of  new  by  reference  is  deprecated  in  C:\wamp\www\evo\includes\functions_evo.php  on  line  1075
 
 Deprecated:  Assigning  the  return  value  of  new  by  reference  is  deprecated  in  C:\wamp\www\evo\includes\functions_evo.php  on  line  1083
 
 Deprecated:  Assigning  the  return  value  of  new  by  reference  is  deprecated  in  C:\wamp\www\evo\includes\functions_evo.php  on  line  1094
 
 Deprecated:  Assigning  the  return  value  of  new  by  reference  is  deprecated  in  C:\wamp\www\evo\includes\functions_evo.php  on  line  1112
 
 Deprecated:  Assigning  the  return  value  of  new  by  reference  is  deprecated  in  C:\wamp\www\evo\includes\classes\class.variables.php  on  line  785
 
 Deprecated:  Function  eregi()  is  deprecated  in  C:\wamp\www\evo\includes
 sncb_func.php  on  line  35                

 
 And  thats  only  in  the  header,  I  get  tond  of  them.
 
 Ive  tried  changing  error  reporting  in  php.ini  and  also  had  a  play  around  with  the  debugger  class,  but  I  just  cannot  get  the  errors  to  disappear.
 
 Any  ideas  on  what  other  files  would  be  changing  the  error  settings?
 
 Thanks
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Lonestar
Site Admin
Site Admin
Xtreme Developer
Xtreme Developer




Joined: Oct 09, 2008
Posts: 425

Reputation: 58.3
votes: 3
blank.png


Status: Offline
PostPosted: Sat Aug 01, 2009 8:39 am Post subject: No icon Re: deprecated errors Reply with quote

 link  to  ur  site  please?
Back to top
View user's profile Send private message Send e-mail
travo



Gender: Gender:Male
Joined: Jan 21, 2009
Age: 24
Posts: 486
Location: Australia
Reputation: 65.1
votes: 2
australia.png


Status: Offline
PostPosted: Sat Aug 01, 2009 8:48 am Post subject: No icon Re: deprecated errors Reply with quote

 Their  on  localhost...  Ill  open  up  the  ports  for  a  bit...  Here  is  one  of  the  sites  link
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Sponsor
webstorm.jpg
travo



Gender: Gender:Male
Joined: Jan 21, 2009
Age: 24
Posts: 486
Location: Australia
Reputation: 65.1
votes: 2
australia.png


Status: Offline
PostPosted: Sat Aug 01, 2009 5:49 pm Post subject: No icon Re: deprecated errors Reply with quote

 I  found  the  problem...  Turns  out  E_NOTICE  doesnt  include  E_DEPRECATED]
 
 Heres  how  I  fixed  it,  if  anyone  else  has  same  problem
 
 In  mainfile.php,  move  
                                                 
PHP:                
@require_once(NUKE_CLASSES_DIR.'class.debugger.php');                 
 up  above  line  163,  which  is                                                    
PHP:                
if (GZIPSUPPORT && !ini_get('zlib.output_compression') && isset($_SERVER['HTTP_ACCEPT_ENCODING']) && eregi('gzip'$_SERVER['HTTP_ACCEPT_ENCODING'])) {                 

 
 In  includes/classes/class.debugger.php,  change  both  instances  of  
                                                 
PHP:                
E_ALL E_NOTICE                 
 to                                                    
PHP:                
E_ALL ^ ~E_NOTICE ^ ~E_DEPRECATED                 

 
 
 And  all  of  the  errors  should  disappear.
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
bjarbj78




Joined: Jan 31, 2009
Posts: 109
Location: The Universe
Reputation: 10.6
blank.png


Status: Offline
Web Control Panel: CPanel v11.25.0-RELEASE
PostPosted: Wed Aug 19, 2009 5:11 pm Post subject: No icon Re: deprecated errors Reply with quote

                                                   
travo  wrote  (View  Post):                
I  found  the  problem...  Turns  out  E_NOTICE  doesnt  include  E_DEPRECATED]
 
 
 In  includes/classes/class.debugger.php,  change  both  instances  of                                                    
PHP:                
E_ALL E_NOTICE                 
 to                                                    
PHP:                
E_ALL ^ ~E_NOTICE ^ ~E_DEPRECATED                 

 
 
 And  all  of  the  errors  should  disappear.                

 
 You  only  need  to  do  the  last  change.  Error  gone  here  with  XAMPP  v.1.7.2(PHP  5.3.0)
Back to top
View user's profile Send private message
travo



Gender: Gender:Male
Joined: Jan 21, 2009
Age: 24
Posts: 486
Location: Australia
Reputation: 65.1
votes: 2
australia.png


Status: Offline
PostPosted: Mon Aug 24, 2009 6:00 am Post subject: No icon Re: deprecated errors Reply with quote

 I  was  getting  errors  that  eregi  was  deprecated  if  debugger  was  included  afterwards  (I  like  to  have  all  errors  showing  for  when  Im  working  on  my  own  stuff)
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Sponsor
phpstorm.jpg
killigan
Xtreme Developer
Xtreme Developer
DFG Developer
DFG Developer



Gender: Gender:Male
Joined: Oct 08, 2008
Posts: 2442

Reputation: 35012.3
votes: 6
usa.png


Status: Offline
PostPosted: Mon Aug 24, 2009 6:55 am Post subject: No icon Re: deprecated errors Reply with quote

 Well,  that  is  the  shortcut  to  fixing  it  correctly.  We  are  aware  that  the  php  5.3.0  switched  ereg/eregi  to  preg_match.  You  can  use  your  fix  to  simple  shut  the  error  reporting  off  but  doesn't  do  anything  for  the  problem.  We  are  working  on  this  and  will  get  an  update  out  as  soon  as  possible  for  those  that  do  use  local  servers  or  have  a  host  that  already  switched  to  PHP  5.3.0.
Back to top
View user's profile Send private message Visit poster's website Visit member's Facebook: 154164544594519
Brahma



Gender: Gender:Male
Joined: Sep 28, 2009
Posts: 4

Reputation: 0.5
italy.png


Status: Offline
PostPosted: Wed Dec 22, 2010 7:23 pm Post subject: No icon Re: deprecated errors Reply with quote

 THANKSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS
 ^______________^
Back to top
View user's profile Send private message
Teo



Gender: Gender:Male
Joined: Jul 17, 2009
Age: 36
Posts: 491
Location: In your GF's bed!!
Reputation: 70.2
votes: 3
italy.png


Status: Offline
PostPosted: Fri Dec 23, 2011 4:48 am Post subject: No icon Re: deprecated errors Reply with quote

                                                   
killigan  wrote  (View  Post):                
Well,  that  is  the  shortcut  to  fixing  it  correctly.  We  are  aware  that  the  php  5.3.0  switched  ereg/eregi  to  preg_match.  You  can  use  your  fix  to  simple  shut  the  error  reporting  off  but  doesn't  do  anything  for  the  problem.  We  are  working  on  this  and  will  get  an  update  out  as  soon  as  possible  for  those  that  do  use  local  servers  or  have  a  host  that  already  switched  to  PHP  5.3.0.                

 
 Hi,  is  there  already  this  stuff?  i  need  to  convert  a  theme:  MG-gs04-001  i'm  using  right  now  this  one  for  a  site  and  i  need  it  working  with  php  5.3.0  and  xtreme  2.0.9d  but  the  theme  included  in  your  downloads  doesnt  work!
 
 let  me  know  plz!  happy  xmas  holidays
 
 Teo.
Back to top
View user's profile Send private message Visit poster's website Visit member's Facebook: 232833186770739
Sponsor
webstorm.jpg
Display posts from previous:
Post new topic  Reply to topic   printer-friendly view Evolution-Xtreme Forum Index ->  General Chat All times are UTC - 5 Hours
Page 1 of 1


 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Related topics
 Topics   Replies   Author   Views   Last Post 
No new posts loads of errors 6 redhotkebab 3856 Sat Feb 11, 2012 7:32 pm
WQQDY View latest post
No new posts Multiple Errors Plus Error Log 42 odawgg 12473 Mon Jan 31, 2011 11:34 pm
Gershak View latest post
No new posts Upgrade from Nuke - A Few Errors 23 JoeBoB 12462 Mon Nov 15, 2010 7:45 pm
hypnoscope View latest post
No new posts errors on install 1 theshackie1 1903 Mon Aug 30, 2010 4:00 pm
killigan View latest post
No new posts [ Poll ] Errors, Errors and More User Errors, Help! 14 Ruphus 6613 Sat Jan 30, 2010 7:33 am
Ruphus View latest post
 




Powered by phpBB © 2001, 2006 phpBB Group
EvoXtreme Theme by SgtLegend ©
Forums ©