Anonymous,

Please Login or Register
Download Nuke Evolution Xtreme today for a CMS you can enjoy using and sharing with your friends!
[ Download Now ]
Forum Index  ·  Search  ·  Usergroups  ·  Edit your profile  ·  Members  ·  Login, Check Messages
Arcade  ·  Ranks  ·  Staff  ·  Statistics  ·  Board Rules  ·  Forum FAQ  ·  Log in

Search for at
Evolution-Xtreme Advanced Search


+  
Latest Site News   Next 5 >>  
 Forum   Author   Replies   Last Post 
File Repository 1.0.0 Released Announcements! Lonestar 0 Tue Apr 26, 2016 6:44 am
Lonestar View latest post
Image Repository Released Announcements! Lonestar 1 Mon Oct 27, 2014 7:39 pm
Lonestar View latest post
So what happened to us? Announcements! SgtLegend 0 Tue May 06, 2014 12:32 am
SgtLegend View latest post
[PROGRESS] Nuke Evolution Xtreme 2.0.9e Announcements! SgtLegend 2 Sun May 27, 2012 6:25 pm
SgtLegend View latest post
European Cookie Law Announcements! SgtLegend 0 Sat May 26, 2012 7:33 am
SgtLegend View latest post
   
Recent Topics   Next 15 >>  
 Forum   Author   Replies   Last Post 
Evo staff looking for some volunteers. Community Announcements coRpSE 20 Thu Jul 02, 2015 9:19 am
Depresjon2 View latest post
Evo Xtreme 2.0.9D Updated for PHP 5.6 General Support coRpSE 121 Thu Mar 23, 2017 3:57 pm
casterdon View latest post
[ MOD ] - Honeypot V2.2 AntiBot Module Security coRpSE 106 Tue Nov 22, 2016 11:30 am
coRpSE View latest post
Possible new Admin area layout Comments and Suggestions Lonestar 18 Wed Sep 14, 2016 11:37 am
Blackou View latest post
jQuery update General Support Lonestar 2 Wed May 11, 2016 4:49 pm
Charles64 View latest post
Deutsche Sprachdatei - german language files German DT50R 7 Thu Jan 28, 2016 7:04 am
DT50R View latest post
[FIX] Correct Cookie Settings (Invalid Session Error) Quick fixes killigan 110 Fri Mar 20, 2015 1:06 pm
Macdaddy View latest post
Looking for coRpSE? He is gone till May. General Chat coRpSE 4 Sun Mar 26, 2017 6:50 pm
coRpSE View latest post
Think I got hit with malware somehow General Support bobdude 10 Sun Mar 26, 2017 6:44 pm
coRpSE View latest post
error log Bugs Redcougarxr7 31 Tue Mar 21, 2017 8:46 pm
coRpSE View latest post
I seem to be locked out of my website Smile General Support storm 4 Sat Mar 11, 2017 12:29 pm
coRpSE View latest post
Site gone off General Support GI_ 3 Fri Mar 03, 2017 11:21 am
Lonestar View latest post
Norwegian Language Multilingual Support dogbone 0 Wed Mar 01, 2017 10:43 pm
dogbone View latest post
Arcade General Support Reaper2388 59 Sun Feb 26, 2017 7:13 pm
pholix View latest post
all blocks General Support Worfwarrior 6 Sat Feb 25, 2017 4:41 pm
coRpSE View latest post

Error in old module "MS-Infoblock"

 
Post new topic    Reply to topic    printer-friendly view   Thank Post    Evolution-Xtreme Forum Index -> Modules
View previous topic :: View next topic  
Author Message
Tchargal




Joined: Jul 31, 2013
Posts: 6

Reputation: 0.8


Status: Offline
PostPosted: Sat Aug 22, 2015 4:12 am Post subject: No icon Error in old module "MS-Infoblock" Reply with quote

 Bonjour,
 
 Sorry  for  my  bad  english...  :)
 
 I  have  a  old  Php-Nuke  module  "MS-Infoblock"  and  i  have  a  deprecated  error  :  
 Deprecated:  Function  ereg_replace()  is  deprecated  in  /home/xxxxxx/www/blocks/block-MS-InfoBlock-1.php  
 on  lines  52,  53  55  56
 
                   $link  =  ereg_replace(  ".*<link>",  "",  $items[  $i  ]  );
                   $link  =  ereg_replace(  "</link>.*",  "",  $link  );
                   $link  =  stripslashes(check_html($link,  "nohtml"));
                   $title2  =  ereg_replace(  ".*<title>",  "",  $items[  $i  ]  );
                   $title2  =  ereg_replace(  "</title>.*",  "",  $title2  );
 
 Can  anyone  help  me  to  replace  whith  the  good  syntaxe  preg_match
 
 Thank's  for  advance...


Last edited by Tchargal on Sat Aug 22, 2015 9:41 am; edited 1 time in total
Back to top
View user's profile Send private message
Shadz



Gender: Gender:Male
Joined: Aug 15, 2012
Age: 30
Posts: 296
Location: Nottingham
Reputation: 38
votes: 1
uk.png


Status: Offline
Web Control Panel: cPanel
PostPosted: Sat Aug 22, 2015 7:51 am Post subject: No icon Re: Error in old module "MS-Infoblock" Reply with quote

 Hi  Tchargal,
 
 
                                                 
Code:                
 $link  =  ereg_replace(  ".*<link>",  "",  $items[  $i  ]  );  
                 $link  =  preg_replace(  "</link>.*",  "",  $link  );  
                 $link  =  stripslashes(check_html($link,  "nohtml"));  
                 $title2  =  preg_replace(  ".*<title>",  "",  $items[  $i  ]  );  
                 $title2  =  preg_replace(  "</title>.*",  "",  $title2  );  
                 

 
 Copy  and  paste  the  code  that  I  have  put  above  and  it  will  no  longer  be  deprecated  mate.
 You  should  be  good  to  go  after  that,  remember  before  any  edits  you  should  backup  your  file/files
 just  encase
Back to top
View user's profile Send private message Visit poster's website
Tchargal




Joined: Jul 31, 2013
Posts: 6

Reputation: 0.8


Status: Offline
PostPosted: Sat Aug 22, 2015 10:22 am Post subject: No icon Re: Error in old module "MS-Infoblock" Reply with quote

 Thank's  for  your  replie  Shadz,
 But  it  dont  work.  I  have  this  error  message  :  
 Warning:  preg_replace()  [function.preg-replace]:  No  ending  delimiter  '.'  found  in  /home/..............
 
 15mn  later,  I  found  the  error  :  fonction  preg-replace  need  a  delimiter  in  the  regex  !
 
 The  good  code  :
 
 
                                                 
PHP:                
            $link preg_replace"/.*<link>/""//"$items$i ] );
            
$link preg_replace"/</link>.*/""//"$link );
            
$link stripslashes(check_html($link"nohtml"));
            
$title2 preg_replace"/\.*<title>\/""//"$items$i ] );
            
$title2 preg_replace"/\</title>.*\/""//"$title2 ); 
               

 
 Merci  :)
 
 PS  :  If  anyone  want  the  MS-Infoblock,  send  me  a  mail  or  MP  !
Back to top
View user's profile Send private message
Sponsor
phpstorm.jpg
Lonestar
Site Admin
Site Admin
Xtreme Developer
Xtreme Developer




Joined: Oct 09, 2008
Posts: 425

Reputation: 58.3
votes: 3
blank.png


Status: Offline
PostPosted: Sat Aug 22, 2015 2:21 pm Post subject: No icon Re: Error in old module "MS-Infoblock" Reply with quote

 Please  attach  the  file  in  this  post,  Will  make  it  a  lot  easier  to  repair  faults.
Back to top
View user's profile Send private message Send e-mail
Tchargal




Joined: Jul 31, 2013
Posts: 6

Reputation: 0.8


Status: Offline
PostPosted: Sat Aug 22, 2015 5:28 pm Post subject: No icon Re: Error in old module "MS-Infoblock" Reply with quote

                                                   
Lonestar  wrote  (View  Post):                
Please  attach  the  file  in  this  post,  Will  make  it  a  lot  easier  to  repair  faults.                

 
 In  the  file  attachement,  the  complet  module  "MS_Info_block_v2.03  PRO  For  PHP-Nuke  7.6-7.8.zip"
 
 MS-InfoBlock  is  a  administrator  Wizard  Tool  to  help  you  to  create  very  easily  Information  Blocks.  Just  add  the  text,  links,  pictures  etc  easily  in  a  wizard.
 This  information  will  then  be  right  away  present  in  your  Info-Block.

 
 The  bad  files  is  :  blocks/block-MS-InfoBlock-1.php,  blocks/block-MS-InfoBlock-2.php,  blocks/block-MS-InfoBlock-3.php,  blocks/block-MS-InfoBlock-4.php  in  lines  52,53,55,56
 
 Bonsoir  de  france  Smile
Back to top
View user's profile Send private message
Display posts from previous:
Post new topic  Reply to topic   printer-friendly view   Thank Post Evolution-Xtreme Forum Index ->  Modules All times are UTC - 5 Hours
Page 1 of 1


 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Related topics
 Topics   Replies   Author   Views   Last Post 
No new posts anyone? 13 SCT951 6530 Fri Feb 20, 2015 11:35 am
Houdini_fl View latest post
No new posts Does anyone know about this exploit ? Should we be careful 8 Redcougarxr7 6655 Fri Jan 06, 2012 3:50 pm
w2ibc View latest post
No new posts Can Anyone Explain this Log Post 15 RafaS 9393 Wed Jul 06, 2011 1:45 pm
SouDou View latest post
No new posts anyone here use SSL ? 5 SnakZ 3415 Fri Feb 25, 2011 11:35 pm
SgtLegend View latest post
No new posts Can anyone tell me which version i have? 5 Evil_Blue 3783 Sat Jan 15, 2011 6:10 pm
metalsensi View latest post
 




Powered by phpBB © 2001, 2006 phpBB Group
EvoXtreme Theme by SgtLegend ©
Forums ©